
 January 2007

New Features

AutoCAD   2008®



Copyright © 2007 Autodesk, Inc.
All Rights Reserved

This publication, or parts thereof, may not be reproduced in any form, by any method, for any purpose. 

AUTODESK, INC., MAKES NO WARRANTY, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO ANY IMPLIED 
WARRANTIES OF MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE REGARDING THESE MATERIALS, AND MAKES SUCH 
MATERIALS AVAILABLE SOLELY ON AN "AS-IS" BASIS. 

IN NO EVENT SHALL AUTODESK, INC., BE LIABLE TO ANYONE FOR SPECIAL, COLLATERAL, INCIDENTAL, OR CONSEQUENTIAL 
DAMAGES IN CONNECTION WITH OR ARISING OUT OF ACQUISITION OR USE OF THESE MATERIALS. THE SOLE AND EXCLUSIVE 
LIABILITY TO AUTODESK, INC., REGARDLESS OF THE FORM OF ACTION, SHALL NOT EXCEED THE PURCHASE PRICE, IF ANY, OF THE 
MATERIALS DESCRIBED HEREIN. 

Autodesk, Inc., reserves the right to revise and improve its products as it sees fit. This publication describes the state of this product at 
the time of its publication, and may not reflect the product at all times in the future. 

Autodesk Trademarks
The following are registered trademarks or trademarks of Autodesk, Inc., in the USA and other countries: 3DEC (design/logo), 
3December, 3December.com, 3ds Max, ActiveShapes, Actrix, ADI, Alias, Alias (swirl design/logo), AliasStudio, Alias|Wavefront 
(design/logo), ATC, AUGI, AutoCAD, AutoCAD Learning Assistance, AutoCAD LT, AutoCAD Simulator, AutoCAD SQL Extension, 
AutoCAD SQL Interface, Autodesk, Autodesk Envision, Autodesk Insight, Autodesk Intent, Autodesk Inventor, Autodesk Map, Autodesk 
MapGuide, Autodesk Streamline, AutoLISP, AutoSnap, AutoSketch, AutoTrack, Backdraft, Built with ObjectARX (logo), Burn, Buzzsaw, 
CAiCE, Can You Imagine, Character Studio, Cinestream, Civil 3D, Cleaner, Cleaner Central, ClearScale, Colour Warper, Combustion, 
Communication Specification, Constructware, Content Explorer, Create>what's>Next> (design/logo), Dancing Baby (image), 
DesignCenter, Design Doctor, Designer's Toolkit, DesignKids, DesignProf, DesignServer, DesignStudio, Design|Studio (design/logo), 
Design Your World, Design Your World (design/logo), DWF, DWG, DWG (logo), DWG TrueConvert, DWG TrueView, DXF, EditDV, 
Education by Design, Extending the Design Team, FBX, Filmbox, FMDesktop, GDX Driver, Gmax, Heads-up Design, Heidi, HOOPS, 
HumanIK, i-drop, iMOUT, Incinerator, IntroDV, Kaydara, Kaydara (design/logo), LocationLogic, Lustre, Maya, Mechanical Desktop, 
MotionBuilder, ObjectARX, ObjectDBX, Open Reality, PolarSnap, PortfolioWall, Powered with Autodesk Technology, Productstream, 
ProjectPoint, Reactor, RealDWG, Real-time Roto, Render Queue, Revit, Showcase, SketchBook, StudioTools, Topobase, Toxik, Visual, 
Visual Bridge, Visual Construction, Visual Drainage, Visual Hydro, Visual Landscape, Visual Roads, Visual Survey, Visual Syllabus, Visual 
Toolbox, Visual Tugboat, Visual LISP, Voice Reality, Volo, and Wiretap. 

The following are registered trademarks or trademarks of Autodesk Canada Co. in the USA and/or Canada and other countries: 
Backburner, Discreet, Fire, Flame, Flint, Frost, Inferno, Multi-Master Editing, River, Smoke, Sparks, Stone, Wire.

Third-Party Trademarks
All other brand names, product names, or trademarks belong to their respective holders.

Third-Party Software Program Credits
ACIS Copyright © 1989-2001 Spatial Corp. 

Copyright © 1999-2000 The Apache Software Foundation.  All rights reserved.  This product includes software developed by the 
Apache Software Foundation (http://www.apache.org) subject to its license terms and conditions 
(http://xml.apache.org/dist/LICENSE.txt).

Typefaces from the Bitstream ®  typeface library Copyright © 1992.

HLM © Copyright D-Cubed Ltd. 1996-2006.  HLM is a trademark of D-Cubed Ltd.

AutoCAD ® 2008 and AutoCAD LT ® 2008 are produced under a license of data derived from DIC Color Guide ® from Dainippon Ink 
and Chemicals, Inc. Copyright © Dainippon Ink and Chemicals, Inc. All rights reserved. DIC and DIC Color Guide are registered 
trademarks of Dainippon Ink and Chemicals, Inc.

Portions of this software are based on the work of the Independent JPEG Group.

Active Delivery™ 2.0 © 1999-2004 Inner Media, Inc.  All rights reserved.

ISYS and the ISYS logo are registered trademarks or trademarks of ISYS ®  Search Software Inc

Copyright © 1988-1997 Sam Leffler.  Copyright © 1991-1997 Silicon Graphics, Inc.

Copyright © Lingea s.r.o. 2006.

The New Features Workshop contains Macromedia Flash™  Player software by Macromedia, Inc. Copyright © 1995-2005 Macromedia, 
Inc.  All rights reserved.  Macromedia ® and Flash ®  are registered trademarks or trademarks of Adobe Systems Incorporated in the 
United States or other countries. 

Copyright © 1996-2006 Macrovision Corporation.  All rights reserved.

Copyright © 1996-2006 Microsoft Corporation. All rights reserved

Copyright © 2002 Joseph M. O'Leary.



PANTONE ® Colors displayed in the software application or in the user documentation may not match PANTONE-identified standards.  
Consult current PANTONE Color Publications for accurate color.  

PANTONE ® and other Pantone, Inc. trademarks are the property of Pantone, Inc. © Pantone, Inc., 2004.

Pantone, Inc. is the copyright owner of color data and/or software which are licensed to Autodesk, Inc., to distribute for use only in 
combination with certain Autodesk software products.  PANTONE Color Data and/or Software shall not be copied onto another disk 
or into memory unless as part of the execution of this Autodesk software product.

Typefaces from Payne Loving Trust © 1992, 1996. All rights reserved.

RAL DESIGN © RAL, Sankt Augustin, 2004.

RAL CLASSIC © RAL, Sankt Augustin, 2004.

Representation of the RAL Colors is done with the approval of RAL Deutsches Institut für Gütesicherung und Kennzeichnung e.V. (RAL 
German Institute for Quality Assurance and Certification, re. Assoc.), D-53757 Sankt Augustin.

This product includes code licensed from RSA Security, Inc.  Some portions licensed from IBM are available at 
http://oss.software.ibm.com/icu4j/.

The Sentry Spelling-Checker Engine Copyright © 1994-2003 Wintertree Software, Inc.

Portions of this product include one or more Boost libraries.  Use of the Boost libraries is subject to its license agreement  
http://www.boost.org/LICENSE_1_0.txt. 

GOVERNMENT USE
Use, duplication, or disclosure by the U.S. Government is subject to restrictions as set forth in FAR 12.212 (Commercial Computer 
Software-Restricted Rights) and DFAR 227.7202 (Rights in Technical Data and Computer Software), as applicable.





Contents

Introduction and Setup    .    .    .    .    .    .    .    .    .    .    .  1

Dimension Enhancements.    .    .    .    .    .    .    .    .    .    .  3
Design and Visualize the Deck in 3D . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 4
Space and Align Dimensions Automatically  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 5
Locate Dimension Text Anywhere  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 9
Break Dimension Lines  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 10

Leader Enhancements .    .    .    .    .    .    .    .    .    .    .    .13
Create a Multileader Object . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 14
Use Grips with Multileaders  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 15
Add and Remove Leader Lines  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 15
Align the Arrowheads  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 16
Use Multileader Styles  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 18
Create Reference Labels (Bubbles)  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 19
Arrange Multileaders  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 21

Multiline Text Enhancements .    .    .    .    .    .    .    .    .    .23
Control Multiline Text Formatting . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 24
Control Paragraph Spacing  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 27
Control Line Spacing  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 28
Check Spelling . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 29



vi | Contents
Table Enhancements and Data Links .    .    .    .    .    .    .   31
Import a Spreadsheet . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 32
Modify the Table . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 35
Interface Features . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 37
Test the Data Link  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 38
Cell Styles  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 43

Layer Display Enhancements   .    .    .    .    .    .    .    .    .   45
Override Layer Properties in Layout Viewports . . . . . . . . . . . . . . . . . . . . . . . . . . . . 46
Control Layers in DWF Underlays . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 49
Control Layer Fading  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 53

Automatic Annotation Scaling .    .    .    .    .    .    .    .    .   55
Create Annotation in Model Space  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 56
Set Scales for Annotative Objects  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 59
Adjust Annotative Objects  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 61
Make Existing Objects Annotative  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 62
What Should You Do Next? . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 64

New and Changed Commands and System Variables .    .   65
Commands  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 66
System Variables . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 72



Introduction and Setup

For use with the AutoCAD 2008 New Features guide only. 
Reproduction of this image is prohibited.

Welcome to AutoCAD 
2008

Across the world, people are 
installing and becoming familiar 
with AutoCAD 2008.

To make the learning process as 
easy as possible, we have 
designed this guide to provide

❚ An easy overview to the major 
new features

❚ Immediate hands-on 
experience

❚ Realistic files useful for 
additional experiments

❚ Chapters that can each be 
completed in a single lunch 
break

❚ References for further study

Setup

Set the workspace to AutoCAD 
Classic.

The tutorial files that you will be 
using are located in the 
following folder:

\Program Files\AutoCAD 
2008\Help\newfeatures

Note If you are new to 
AutoCAD, first complete the 
exercises in the AutoCAD 2008 
Getting Started Guide, which is 
included as a PDF file in the 
product CD.© 2002 Buckminster Fuller Institute and Jim Knighton.  Coordinate 

transformation software written by Robert W. Gray and modified by 
Jim Knighton. 

Unlike the popular Mercator projection, Buckminster Fuller's 
Dymaxion™   world map suffers no obvious distortion. The genius of his 
invention is not that it can fold into a regular 20-sided icosohedron, 
but that it can be laid flat. For posters of this map and for more 
information about his work, visit the Buckminster Fuller website at 
www.bfi.org.

™





Dimension Enhancements

Deck design 
courtesy of Dieter Schlaepfer
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Introduction

❚ Before it was built, the deck 
shown in the illustration was 
designed using AutoCAD's 3D 
solid modeling features.

❚ The 3D model was then 
converted into a 2D drawing 
using the FLATTEN Express 
Tool. Alternatively, the 
FLATSHOT command could 
have been used.

❚ Using both the 3D model and 
the 2D drawing, the 
contractor could easily 
visualize the design, plan the 
framing, and anticipate 
complications.

Further study…

To become more familiar with 
the power of 3D solid modeling, 
view the PDF file of Building Your 
World included on your install 
media.
Design and Visualize the Deck in 3D

1 Open the drawing, 01 Deck Solid.dwg.

2 From the View menu, click Orbit > Constrained Orbit.

3 Click and drag to view the deck in 3D.

4 Close the file.
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Spacing Dimensions

❚ This is the plan view of the 
deck without the deck cover. 
The drawing uses several 
types of dimensions, which, 
for the purposes of this 
exercise, need modification. 

❚ As you can see, the baseline 
dimensions are crowded and 
would normally require 
several minutes to adjust 
manually.

❚ You will space these 
dimensions automatically 
from a base dimension that 
you select, and at a distance 
that you specify.
Space and Align Dimensions 
Automatically

1 Open the drawing, 01 Deck Plan.dwg.

2 Zoom into the right side of the deck showing the 
baseline dimensions.

3 From the Dimension menu, click Dimension Space.
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❚ The base dimension that you 
select will remain stationary.

Note After you select the 
base dimension, you are 
immediately prompted to 
select the dimensions to be 
modified. Resist the urge to 
press ENTER after selecting 
the base dimension.

❚ The Auto option uses an 
automatic spacing based on 
the current value of the 
DIMDLI system variable.

❚ The result is a nice, evenly 
spaced set of baseline 
dimensions.

Things to Try…

Undo the previous operation 
and try using several different 
dimensions as the base 
dimension. Also try using the 
Auto option.
4 At the prompt, click the dimension to use as the 
reference. Then, select the remaining dimensions 
using a crossing selection and press ENTER.

5 Enter the spacing distance in drawing units: in this 
case, enter 15.
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Aligning Dimensions

❚ You can also quickly align 
continued dimensions. 

❚ As you can see, the linear 
dimensions are not aligned 
and would also normally 
require several minutes to 
adjust manually. 

❚ Who dimensioned this 
drawing anyway?

❚ You will space these 
dimensions automatically 
from a base dimension that 
you select, and at a distance 
of 0.

❚ All the selected dimensions 
are now in a straight line.

❚ But it's not perfect…
1 Perform a Zoom Extents and then zoom into the 
lower-left area of the deck plan as shown.

2 On the Dimension menu, click Dimension Space.

3 At the prompt, click the dimension to use as the 
reference. Then, select the remaining dimensions 
using a crossing selection and press ENTER.

4 Enter the spacing distance in drawing units: in this 
case, enter 0.
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Final Clean Up

❚ This is not a new feature, but 
you don't want to leave the 
overlapped dimension text 
alone.

❚ You can change the setting of 
the DIMTMOVE system 
variable for the selected 
dimension directly from the 
Properties palette.

❚ While it is likely that your 
dimensioning standards differ 
from those used in the 
exercise, you can get an idea 
of the power of the new 
dimensioning features in 
AutoCAD.

Things to Try…

Revise the dimensions using 
your own dimension styles.
1 Select the overlapping dimensions as shown.

2 Open the Properties palette, and under the Fit 
category, click Text Movement. On the drop-down 
list, click "Move text, add leader." Close or hide the 
Properties palette.

3 Using grips, drag the dimension text into place as 
shown.
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Angular Dimensions

❚ A new option has been added 
for creating angular 
dimensions.

❚ The Quadrant option lets you 
choose the angle that you 
want to dimension. This 
allows you place the 
dimension text anywhere.

❚ Where you click controls both 
the location of the dimension 
text and the length of the 
extended dimension line.

Things to Try…

Extended dimension lines are 
also available for radial 
dimensions. 

Create an arc anywhere on the 
drawing and then create a radius 
or diameter dimension, moving 
the dimension text location off 
the end of the selected arc. 
Locate Dimension Text Anywhere

1 Erase the angular dimension.

2 On the Dimension menu, click Angular.

3 Click the two lines, enter Q (quadrant), and click in 
the quadrant as shown.

4 Move your cursor to the left and click the location of 
the dimension text as shown.
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Crossing Dimensions

❚ While it is not considered 
good drafting practice to 
cross dimension or extension 
lines, you do see drawings 
where it is done.

❚ Instead of exploding and 
editing dimension geometry, 
to create breaks manually, 
you can save a lot of time 
creating automatic breaks 
when necessary.

❚ Selecting a single dimension 
at a time is not as fast, but it 
gives you more control over 
what is to be broken.
Break Dimension Lines

1 Perform a Zoom Extents and zoom into the lower-
right area of the deck plan.

2 On the Dimension menu, click Dimension Break.

3 At the prompt, enter m (for multiple) and specify a 
crossing selection as shown.
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❚ All objects that intersect the 
selected dimensions act as 
locations that create breaks.

❚ The resulting breaks are 
dynamic, changing when 
either the broken dimension 
or the object is moved.

❚ Notice how the breaks 
change when you stretch the 
dimension.

Things to Try…

Create breaks in the other 
dimensions on the drawing. 

Notice that when the extension 
lines of two dimensions overlap, 
both dimensions need to be 
broken to display the dimension 
breaks on their common 
extension lines.

Repeat the Dimension Break 
operation, but this time, select 
each dimension individually and 
try each of the options. 
4 At the prompt, press ENTER twice.

5 Select the diagonal dimension. Click the grip as 
shown and move it to a new location.



12 | Dimension Enhancements

Jogged Dimensions

❚ When dimensioning large 
objects, you might need to 
create jogged breaks in linear 
dimension lines.

Things to Try…

On the Dimension menu, use 
Jogged Linear to remove the jog.

Further Study…

Review these commands and 
associated User's Guide topics in 
the Help system:

DIMSPACE

DIMBREAK

DIMJOGLINE

DIMINSPECT
1 Perform a Zoom Extents on the deck plan. Grip edit 
the dimension text as shown and zoom into the 
upper-right area of the deck.

2 On the Dimension menu, click Jogged Linear. Select 
the dimension, and click the dimension line to the 
left of the dimension text.

3 Select the jogged linear dimension and use the grip 
on the jog to move it.

4 Close the file without saving it.



Leader Enhancements

"Hawaiian Time" wooden clock courtesy of Clayton Boyer
http://www.lisaboyer.com (click Clayton Boyer’s Clocks)
For use with the AutoCAD 2008 New Features guide only. 
Reproduction of this image is prohibited.
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Multileader Objects

❚ Using a sheet from the plans 
of a wooden clock, you can 
explore some "time-saving" 
features of a new, more 
powerful leader object.

❚ This drawing includes a 
collection of types of leaders 
and bubbles.

Note For the purposes of the 
exercise, this sheet was 
significantly modified from 
the original. 

❚ Notice the red reference 
labels, often known by 
different names. These are 
also multileaders; you will 
create these later.

❚ The length of the landing is 
controlled by a setting in the 
multileader style.

❚ When this value is greater 
than zero, it determines the 
maximum width of the 
multiline text.
Create a Multileader Object

1 Open the drawing, 02 Clock p5.dwg. 

2 Right-click any toolbar and, on the shortcut menu, 
click Multileader to display the Multileader toolbar.

3 Delete the leader "Leather plug."

4 On the Multileader toolbar, click the Multileader 
button.

5 Click to specify the location of the arrowhead. Click 
again to specify the location of the last point, which 
is the beginning of the landing.

6 Enter the text, Leather plug and click OK.
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Notice that the leader is a single 
object and has five grips. For 
Stretch mode

A controls the arrowhead 
location

B controls the opposite end of 
the leader

C controls the length of the 
landing

D controls the location of the 
entire multileader

E controls the alignment of the 
multileader text

Add Leader Lines

❚ When you move the cursor to 
place the head of the new 
leader line, notice that you 
can force it to either side of 
the leader text.

Things to Try…

Add some more leader lines, but 
try to resist adding too many of 
them.
Use Grips with Multileaders

1 Click the multileader to display its grips.

2 Click each grip and adjust its location with your 
mouse.

Add and Remove Leader Lines

1 On the Multileader toolbar, click Add Leader and 
then select the same multileader. 

2 Click a location for the new leader line.
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Okay, this is a little overboard…

❚ But now that there are more 
than a few leader lines, there 
is a nice trick to line them up 
neatly.

❚ You probably already use 
object snap tracking to align 
objects and endpoints. This 
feature is also useful for 
aligning the arrowheads of 
multileaders.
Align the Arrowheads

1 If necessary, turn on object snap tracking.

2 Select the multileader and click the grip at one of the 
arrowheads.
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Align Arrowheads

❚ In addition to grips, you can 
reference any object location 
with object snap turned on.

Remove Leader Lines

❚ After you align the 
arrowheads, you might also 
want to remove some of the 
extra leader lines.

Things to Try…

Remove all of the leader lines. 
Then use the Add Leader button 
to recreate a leader in any 
location.
3 Slide the arrowhead grip from 1 to the grip at 2, down 
to 3, and click.

4 Use the same method to align the rest of the 
arrowheads.

5 On the Multileader toolbar, click Remove Leader and 
remove most of the extra leader lines.
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Multileaders use styles similar to 
dimension styles. If you create 
several multileader styles in your 
drawing template (DWT) files, 
you can access a "library" of 
predefined multileaders.

Use Curved Leaders

❚ To control the leader type in 
specific multileader objects, 
you can navigate to the Type 
option in the MLEADER 
command, or you can use the 
Properties palette to change 
the leader type.

❚ Notice that all multileaders in 
the drawing now use curved 
leader lines.

❚ As with dimensions, it is 
strongly recommended that 
you organize your drawings 
with styles.

Things to Try…

Open the Multileader Style 
Manager and explore the 
settings on each tab.
Use Multileader Styles

1 On the Multileader toolbar, click Multileader Styles.

2 In the Multileader Style Manager, click Modify.

3 On the Leader Format tab, change the type of leader 
to Spline. Click OK and then click Close to accept the 
change.
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Specify a Block

❚ A block named BUBBLE has 
already been defined in the 
drawing.

❚ There are several different 
names commonly used for 
multileaders that use blocks.

❚ There are several predefined 
blocks displayed in the list, 
but it is likely that you will 
need to create blocks that 
conform to your standards.

Things to Try…

Try using several of the 
predefined blocks.
Create Reference Labels (Bubbles)

1 Close and reopen, 02 Clock p5.dwg for a fresh start.

2 Open the Multileader Styles Manager and click New.

3 In the Create New Multileader Style dialog box, under 
New Style Name, enter Bubble, and then click 
Continue.

4 On the Content tab, for Multileader Type, click Block. 
Then, for Source Block, click User Block.
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Create a New 
Multileader Style

❚ Plan on creating several new 
multileader styles for your 
projects.

❚ The Bubble style is now the 
current style. You can now 
easily change multileader 
styles, depending whether 
you want to create a note 
with a leader or a bubble.

❚ Depending on how you work, 
this option might be more 
useful.

❚ Multileaders with blocks can 
also have multiple leader lines 
and can easily be edited.
5 In the Select Custom Block dialog box, click BUBBLE, 
and then click OK.

6 Close the Multileader Style Manager. The Multileader 
toolbar is updated.

7 On the Multileader toolbar, click Multileader and 
create a new bubble.

8 Click Multileader again, but this time, on the 
command line, specify the Content First option. 
Create several new multileaders.

9 Click the multileader at the bottom of the drawing 
and use the grip to change its location as shown.
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Align Multileaders

❚ Once multileaders are placed 
on a drawing, you can align 
them neatly.

❚ You can align all types of 
multileaders. Let's align the 
bubbles.

❚ The multileader that you 
select aligns the others 
vertically to itself, but keeps 
the horizontal spacing 
unchanged.
Arrange Multileaders

1 Zoom into the upper portion of the drawing.

2 Click Align Multileaders.

3 Select the multileaders using a crossing selection and 
press ENTER.

4 At the Select Multileader prompt, click the top 
bubble. 

5 Move your cursor downward along the object snap 
tracking path. 
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Specify the Spacing 

❚ The Options in the 
Multileader Align command 
provide several ways to 
change the horizontal spacing 
between the leaders.

Things to Try…

Create several other types of 
multileaders and align them 
using different alignment 
options.

Use the Multileader Collect 
command to assemble any 
related multileaders with one 
leader.

Further Study…

Review these commands and 
associated User's Guide topics in 
the Help system:

MLEADER

MLEADERALIGN

MLEADERCOLLECT

MLEADEREDIT

MLEADERSTYLE
6 Click a location when the alignment path is vertical.

7 Close the file without saving it.
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Green flag at the Indianapolis 500®

IMS Photo by Dan Helrigel
http://www.indianapolismotorspeedway.com

For use with the AutoCAD 2008 New Features guide only. 
Reproduction of this image is prohibited.



24 | Multiline Text Enhancements

Introduction

❚ When you are racing to finish 
a project, the new formatting 
features that are available for 
multiline text are real winners.

❚ Oh, sorry. The text needs to 
be in two columns for easier 
reading.

❚ Dynamic columns change the 
number of columns 
depending on the width of 
the MTEXT object. Static 
columns specify the number 
of columns to use.

❚ To start out, use static 
columns.
Control Multiline Text Formatting

1 Open the drawing, 03 Indy500.dwg.

2 Open the text file, 03 Indy500.rtf in WordPad or 
Microsoft Word.

3 Highlight the text and copy it to the Windows 
clipboard (CTRL+C). 

4 In AutoCAD, use the MTEXT command to define a 
text box the same size as the empty rectangle. Then 
paste the contents of the clipboard into the text box 
(CTRL+V). Change the text size to .25 inches.

5 Double-click the text. On the Text Formatting 
toolbar, click the Column button, and specify 2 static 
columns. 
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Adjusting the Columns

❚ If you have a wheel mouse or 
similar input device, zoom in 
and out as needed even while 
you edit the text or make 
changes to the columns.

❚ You can adjust the length, 
width, and separation of the 
columns, and the text 
automatically responds.

❚ You can also use grips to 
change the column distances; 
however, the multiline text 
editor provides a greater 
range of options.

Things to Try…

On the Text Formatting toolbar, 
specify 3 static columns and 
make any needed adjustments.
6 Adjust the width of the multiline text object by 
sliding the width adjustment on the right side of the 
ruler (1), sliding the separation adjustment between 
the two columns (2), and sliding the column length 
adjustment (3). Repeat as needed.

7 Move the multiline text object to center it within the 
rectangle.
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Using Precision

❚ With the multiple-column 
feature, you are not limited to 
visual adjustments. You can 
also specify precise distances 
for column width, column 
separation (gutter), and other 
adjustments.

❚ Notice that changing one 
value in the dialog box can 
automatically affect the 
others.

Things to Try…

Changing different numbers 
and types of columns is also very 
smooth. 

Try specifying dynamic columns 
and click OK. Then, adjust the 
column widths on the ruler.
8 Open the Column Settings dialog box.

9 Use this dialog box to enter rounded values for each 
distance. For example, enter 9 for the column width 
and then enter 1 for the gutter width.

10 Repeat with different values and click OK.
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Additional Formatting

What if you need additional 
space between each bullet in the 
right column? 

❚ Bullets are treated as a single 
paragraph.

❚ Notice that the results space 
the bullets, but not each line 
of every bullet.

Things to Try…

Try adjusting various settings to 
become more familiar with their 
effects.
Control Paragraph Spacing

1 Click within any of the bulleted lines or highlight 
them for clarity.

2 On the Text Formatting toolbar, click Paragraph. 

3 In the Paragraph dialog box, click Paragraph Spacing 
and then, under After, enter 0.25. Click OK on the 
Paragraph dialog box.
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Additional Formatting

What if you need additional 
space between each line of text 
in a paragraph? 

❚ Notice that the results are 
applied to each line in the 
current paragraph only, not 
to the entire multiline text 
object.

Things to Try…

Click a paragraph. On the Text 
Formatting toolbar, click the 
Distribute button. Then click the 
Justify button.

Set several tabs on the ruler. 
Click the tab icon to access 
additional types of tabs.
Control Line Spacing

1 Click anywhere within the lower-left paragraph.

2 On the Text Formatting toolbar, click Line Spacing 
and then 1.5x.

3 Click OK on the Text Formatting toolbar dialog box to 
accept the results.
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Highlight and Zoom

❚ Spell checking has been 
significantly improved.

❚ Notice that any words that are 
misspelled or not in the 
current dictionary are 
highlighted, and that 
AutoCAD zooms into the text 
in question.

Note The check spelling 
feature supports 19 
dictionaries, but it does not 
currently support Asian 
languages. However, it still 
could be useful in Asian 
languages for collaborative 
situations that require more 
than one language.

Things to Try…

Add several misspelled words to 
the text. Use Spell Checking to 
find and correct them.
Check Spelling

1 Right-click any toolbar and then click Text on the 
shortcut menu.

2 Click the Spell Check button. In the Check Spelling 
dialog box, click Start.

3 Continue by clicking Ignore to examine the other 
words that might be misspelled.
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Control Spell Checking

❚ With specific control settings, 
you can avoid performing 
spell checks on possibly 
hundreds of irrelevant words.

Things to Try…

Check or clear several options in 
the Check Spelling Settings 
dialog box. Paste some 
additional text into the drawing 
and check for spelling errors.

Further Study…

Review these commands and 
associated User's Guide topics in 
the Help system:

MTEXT

SPELL
4 Click Settings to display the Check Spelling Settings 
dialog box. Examine the new control options 
available.

5 Click cancel, and then close the drawing file.



Table Enhancements and Data Links

Bathroom tile layout
Courtesy of Dieter Schlaepfer



32 | Table Enhancements and Data Links

Introduction

❚ Spreadsheet data used in a 
project might need to be 
displayed in an AutoCAD 
table.

❚ This bathroom tile project 
required visual design and 
planning in AutoCAD, and 
materials, quantity, and cost 
data in Microsoft Excel. 

❚ The walls are laid out flat.

❚ You can import part or all of a 
spreadsheet into an AutoCAD 
table. The data is linked to the 
spreadsheet and can be 
updated in either direction at 
any time. 

❚ Thus, data can be imported 
from the spreadsheet into a 
drawing, or exported from a 
drawing into a spreadsheet.
Import a Spreadsheet

1 Open and examine the drawing, 04 Bath Tiles.dwg.

2 Open and examine the spreadsheet file, 04 Tiles.xls in 
Microsoft Excel.

3 On the Draw menu, click Table. Click From a Data 
Link, and then click the Data Link Manager button.
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Creating a Data Link

❚ A data link is a named path to 
an external data file for 
reference in AutoCAD. 

❚ There are several methods for 
creating links from an 
AutoCAD drawing to a 
spreadsheet. This chapter will 
cover one of them.

❚ Currently, the only data link 
available is to Excel.
4 Click Create a New Excel Data Link.

5 Enter Tiles as the name of the data link. Click OK.

6 Click Browse and select the 04 Tiles.xls spreadsheet.



34 | Table Enhancements and Data Links

Set Data Link Options

❚ You can choose several 
options when you create a 
data link.

❚ By default, all data types are 
converted to text because, 
although AutoCAD supports 
many commonly used data 
types, there are some data 
types that are not supported. 

Locate the Table

❚ A table with the required 
number of rows and columns 
is created automatically with 
the content from the Excel 
spreadsheet.

❚ However, the table is much 
too small, so you need to scale 
it to make it larger.
7 Expand the New Excel Data Link dialog box.

8 Clear the Convert Data Types check box and click the 
Start with Excel Formatting radio button.

9 Click OK to close each dialog box. Then, in the 
drawing, click a location for the table as shown.
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Scale the Table

❚ The point size of the text in 
the spreadsheet determined 
the approximate size of the 
text and the table in the 
drawing.

❚ If you create a data-linked 
table on a layout tab rather 
than in Model space, the 
initial size of the text will be 
closer to what you expect.

❚ The Excel data format is 
preserved in AutoCAD as 
much as possible.

Display the Grips

❚ Grips are available for 
modifying the placement and 
size of the table, and the 
width of each row.

❚ The lock icon indicates that 
the data in the table is 
currently locked. This is the 
default condition. The link 
icon indicates that the data is 
linked to a spreadsheet.
Modify the Table

1 On the Modify menu, click Scale. Locate the base 
point at the lower-left corner of the table. Enter a 
scale factor of 25.

2 Click the outer edge of the table.

3 Move the cursor over the table. Notice the two icons.
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Stretch a Column

❚ Resizing columns and several 
other features of tables have 
not changed significantly 
since the last release.

❚ You can use the light blue 
triangle at the bottom-center 
to split long tables.

Add Color to a Row

❚ Several table controls are 
available only on the 
Properties palette. The 
options that are available 
depend on whether you select 
a cell, column, row, or table.

Things to Try…

Select the edge of the table and 
change its size using the 
Properties palette.

Turn lineweight display on. Click 
row 10. Using the Properties 
palette, click Border Lineweight 
and change several border 
display and color options.
4 Move the cursor onto each grip. Notice the 
information in the tooltips. 

5 Stretch the second column as shown.

6 Click row 10 and open the Properties palette. Using 
the Properties palette, change the Background Fill 
color of the row to yellow. Close the Properties 
palette.
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Table Enhancements

Notice the following table 
enhancements:

❚ Rows and columns are easily 
identified and selected.

❚ The green corners denote the 
limits of the linked area of the 
table.

❚ The light-blue grip in the 
lower-right corner is used to 
automatically fill a series of 
cells with values.

❚ A new toolbar provides a 
variety of options and 
controls.

Things to Try…

Try adding a row or column 
within the linked area of the 
table. Currently, you cannot 
divide the data link area of the 
table.
Interface Features

1 Click the Select All button in the upper left corner of 
the table.

2 Move the cursor over each of the buttons in the Table 
toolbar to display its tooltip. 
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Change the Data

❚ The tiles for the baseboard 
need to be rounded at the top 
edge. This is an extra charge 
added to nine tiles.

❚ The initial values in cells F5 
and G5 were set to 0 and 
$0.00 to maintain their data 
types in AutoCAD.

❚ The 04 Tiles.xls file must be 
closed for AutoCAD to be able 
to import the changes.

❚ It doesn't matter whether you 
select a cell, a row, a column, 
or the entire the table. When 
you update a data link, all the 
changes in the spreadsheet 
are updated.

❚ "Download" in this case 
means the same thing as 
import. 
Test the Data Link

1 In the spreadsheet file, 04 Tiles.xls, change cell F5 to 
9 and G5 to $30 and save the changes. Close the 
spreadsheet file.

2 In the drawing, click row 5.

3 On the Table toolbar, click the Download Changes 
button as shown below.
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❚ You might need to adjust the 
text style of the new data. This 
is why it is a good idea to 
define table and text styles.

❚ The data is updated and the 
total at the bottom of the 
table displays the revised cost 
of the tiles.

Save Data to 
Spreadsheet

❚ You can also export changes 
from the table back into the 
spreadsheet. In this case, you 
decide to add two more 
decorative tiles to the total for 
breakage.

❚ You can lock or unlock the 
data, the formatting, or any 
combination in a table, row, 
column, or cell, or specified 
range. 

❚ You have to change the cost 
manually in the drawing 
because a formula was not 
saved in this cell.

❚ Notice that the total was not 
automatically updated.
1 Click the Select All button in the upper left corner of 
the table. Click the Locking button on the toolbar 
and click Unlocked. 

2 Double-click in cell F8 and change the number from 
12 to 14 and click OK.

3 Double-click in cell G8 and change the number from 
$131.40 to $153.30 and click OK.
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❚ You can select any element in 
the table for this step.

❚ "Upload" in this case means 
the same thing as export.

❚ You can confirm that the data 
was saved to the spreadsheet. 

❚ Notice that the total cost in 
the Excel spreadsheet is 
updated.

❚ To update the total cost in the 
drawing, download the 
changes from the 
spreadsheet. This also updates 
the text formatting.

❚ Notice that the table locks 
automatically after you 
download changes from the 
spreadsheet.
4 Click the Select All button in the upper left corner of 
the table. 

5 Right-click to display the shortcut menu. Click Data 
Links > Upload User Changes to Source File.

6 Open the spreadsheet file, 04 Tiles.xls. 

7 Close the spreadsheet.

8 On the Table toolbar, click the Download Changes 
button as shown below. Click Yes to import the 
changes.

9 With the entire table selected, click the Locking 
button and click Unlocked.
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Add a Column

❚ You can add a column or a 
row outside the data linked 
area of the table. 

❚ Several blocks representing 
the tiles have been saved in 
the drawing. Adding these 
blocks to the table improves 
clarity.
1 Click to select column A. 

2 Click the Insert Column to the Left button.

3 Click to select the A4 cell.
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Insert Blocks

❚ AutoFit automatically scales 
the selected block to fit in the 
cell. 

❚ In this case, it is more helpful 
to change the size of the cell 
to fit the block.

❚ You can double-click each 
block to confirm its name

Things to Try…

Clean up the table by merging 
the cells in row 9 and cells B10 to 
G10.
4 Click the Insert Block button.

5 Click P33 and then clear the AutoFit check box.

6 Insert the rest of the blocks as shown.
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Types of Cells

❚ There are three types of cells: 
Data, Heading, and Title.

❚ It is common that an entire 
row or column is a single type 
of cell. Thus, setting the type 
of cell to By Row/Column is 
similar to setting layer 
properties to BYLAYER.

❚ Notice that the Cell Style is set 
to Row/Column. The Row 
Style is set to Data for the 
entire row. 

Things to Try…

Create several table and cell 
styles. Apply them to the table.

Further Study…

Review these commands and 
associated User's Guide topics in 
the Help system:

DATALINK

DATALINKUPDATE
Cell Styles

1 Click a cell in the table and then open the Properties 
palette.

2 Click each cell to see how the information in the 
Properties palette changes.

3 Click the H10 cell and then click Data Type on the 
Properties palette.

4 Close the drawing and spreadsheet files.
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Floor plan courtesy of Trinity 
Developers, Inc.
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Rationale

For this floor plan, the color 
properties assigned to the layers 
make it clearer and easier to 
work on.

In some cases, you might find it 
convenient to override the 
properties of objects in different 
layout viewports.

For example, you might want to 
do one of the following:

❚ Send a quick check plot to a 
monochrome printer.

❚ Create two layout viewports, 
one in black and white, and 
the other in color.

❚ Create a layout tab that 
displays the color of only one 
of the layers.

❚ Change other property 
assignments by layout 
viewport, such as linetype and 
lineweight
Override Layer Properties in Layout 
Viewports

1 Open the drawing, 05 Floor Plan.dwg. 

2 Click the Layout tab or button. If necessary, double-
click within the layout viewport to access model 
space in that viewport.
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Override the Color

❚ If necessary, resize the Layer 
Properties Manager and the 
VP Color column.

❚ The choices on the shortcut 
menu change depending on 
which column you right-click.

❚ For convenience, the color 
that you right-click in the VP 
Color column sets the default 
color in the Select Color 
dialog box.

❚ The colors in the current 
layout viewport are no longer 
displayed.

❚ Layers with property overrides 
in the current layout viewport 
are highlighted. The overrides 
can be different for each 
layout viewport.

Things to Try…

Use different color overrides for 
each layer. Then try overriding 
some different layer properties.
3 Open the Layer Properties Manager. Right-click in the 
list of layers and click Select All on the shortcut menu.

4 Within the VP Color column on the right side, right-
click on the layer 0 color and click Select Color. 

5 Click OK in the Select Color dialog box and in the 
Layer Properties Manager.

6 View the layers in the Layer control.
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Remove the Overrides

❚ The steps to remove the layer 
property overrides are similar 
to setting them.

Things to Try…

❚ Examine the other choices in 
the Remove Viewport 
Overrides shortcut menu.

❚ Specify several viewport 
overrides in different layout 
viewports. Make different 
layout viewports current.

❚ Remove layout viewport 
overrides selectively: only for 
some layers, only some 
properties, only for the 
current layout viewport.

Further Study…

Review these system variables 
and associated User's Guide 
topics in the Help system:

VPLAYEROVERRIDES

VPLAYEROVERRIDES-MODE
1 In the current layout viewport, open the Layer 
Properties Manager. Right-click in the list of layers 
and click Select All on the shortcut menu.

2 Within the VP Color column, right-click and click 
Remove Viewport Overrides For > Color > In Current 
Viewport Only.

3 Click OK to accept the change and close the Layer 
Properties Manager.

4 Close the drawing without saving it.
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Rationale

Professionals often need to share 
drawing information but may 
not want to release the DWG 
files for a project. In those 
situations, they often provide 
the information as plots, PDF 
files, or DWF files.

Why use DWF?

DWF files have the following 
advantages:

❚ Significantly smaller than PDF 
files

❚ Provide vector rather than 
raster graphics

❚ Can be viewed with the free 
Autodesk® DWF™  Viewer

❚ Can be viewed directly from 
the Autodesk website

❚ Provide object snaps and 
control over layer display

Note DWF files have reduced 
precision. The default 
precision is set to 1200 dpi 
(dots per inch), which is 
controlled in the DWF6 ePlot 
Properties dialog box (custom 
properties).
Control Layers in DWF Underlays

1 Start a new drawing. Use Tutorial-iArch.dwt as the 
drawing template file.

2 Click the Model tab or button.

3 Click Insert menu > DWF Underlay.

4 Select the file, 05 Floor Plan-Model.dwf.

5 In the Attach DWF Underlay dialog box, clear the 
Specify On-Screen options. Click OK.

6 Zoom to extents.



50 | Layer Display Enhancements

Turn Off Layers

❚ Your job is to create a potting 
bench that is 16" wide along 
the hatched wall inside the 
garden area.

❚ Clicking on an object in the 
DWF underlay selects the 
entire DWF underlay.

❚ The display is complicated 
with objects that you do not 
need to see, so you turn off 
several layers.

Note The DWF file was 
plotted with layers turned on. 
This option is available in the 
DWF6 ePlot Properties dialog 
box.

Things to Try…

Plot the floor plan drawing to a 
PDF file using the DWG to 
PDF.pc3 option under Name in 
the Plot dialog box. Compare 
this file to the DWF file.
1 Zoom into the enclosed garden area.

2 Click on any object in the DWF underlay. Then right-
click and click DWF Layers on the shortcut menu.

3 Click the icons to turn off layers 12 HATCH, 20 
ELECTRICAL, and 40 TEXT. Then click OK.
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Control DWF Fade

❚ You decide that the objects in 
the DWF underlay are still a 
little too bright and colorful.

❚ The distance is reported as 
9'4-9/16". In the DWG file, 
the true distance is 9'4-1/2". 
This is a deviation of 1/16" or 
about 1.6 mm. 

❚ For higher precision, the DWF 
file could be created at 2400 
or 4800 dpi instead of the 
default 1200 dpi. Either of 
these settings will report a 
more precise distance.

Things to Try…

Experiment with different fade 
levels from 0 (no fading) to 80 
(maximum fading).
1 At the Command prompt, enter dwfadjust. Select any 
object in the DWF underlay and press ENTER.

2 Set the Fade option to increase the dimming to 60 
(percent).

3 Repeat the DWFADJUST command and set the 
Monochrome option to On.

4 Use the DIST command to measure the distance as 
shown.
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Create the Bench 

❚ After you finish the deluxe 
potting bench, you can 
detach the DWF underlay.

❚ The potting bench drawing is 
now ready for dimensions and 
annotation.

Further Study…

Review these commands and 
associated User's Guide topics in 
the Help system:

DWFADJUST

DWFLAYERS
1 Create a potting bench with the dimensions 112" x 
18". The stainless steel sink is 20" x 14 ", and the 
shelves are 53" x 9".

2 Click Insert menu > External References.

3 Right-click 05 Floor Plan-Model. On the shortcut 
menu, click Detach.

4 Close the drawing file.
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Rationale

When you work on a complex 
drawing that displays a lot of 
objects with different colors, it 
can be easy to become fatigued 
or select the wrong object.

Previously, your only option was 
to completely turn off or freeze 
layers.

Lock and Fade Layers

As you complete the electrical 
work, you notice that the 
bedroom light and fan are not 
shown as hooked up to the wall 
switches. So, you simplify the 
display and lock all layers except 
the one you are working on

❚ Notice that the other layers 
have faded slightly. You can 
increase the fading effect.

❚ A value of 0 turns off the 
fading effect.
Control Layer Fading

1 Open the drawing, 05 Floor Plan.dwg. 

2 Zoom into the master bedroom area.

3 Click Format menu > Layer Tools > Layer Isolate.

4 At the Select Objects prompt, select any magenta 
object on the 20 ELECTRICAL layer and press ENTER.

5 At the Command prompt, enter laylockfadectl. Enter 
80 for the fade percent.
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Work with Faded Layers

❚ Working with the faded layers 
provides a visual reference 
and, because the layers are 
locked, you cannot select 
objects on them by accident.

❚ As you move your cursor over 
objects on locked layers, a 
lock icon is displayed.

Undo Layer Locking

❚ To undo the layer isolation is 
also easy.

Further Study…

Review these commands and 
associated User's Guide topics in 
the Help system:

LAYISO

LAYUNISO

LAYLOCKFADECTL
6 Add two arcs to the fan and light as shown.

7 Click Format menu > Layer Tools > Layer Unisolate.

8 Close the file without saving it.



Automatic Annotation Scaling

Retaining wall drawing courtesy of
David L. English, Architect
Rohnert Park, California
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Rationale

This is a section of a retaining 
wall used as a detail on several 
sheets at different scales. The 
annotation for this drawing 
includes

❚ Text

❚ Hatches

❚ Leaders

❚ Dimensions

❚ Blocks and attributes

In this case, the annotation is 
created in model space for 
convenience and portability.

Normally, you would duplicate 
the annotations at different 
scales and use additional layers 
to control their display at each 
scale in each layout viewport. 
Now, there is a better way.

Create Layout Viewports

❚ You are creating two detail 
views at different scales on the 
same layout for easy 
comparison.
Create Annotation in Model Space

1 Open the drawing, 06 Wall Section.dwg. 

2 Click the Layout tab or button. Use the MVIEW 
command on the command line to create two layout 
viewports as shown. 
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Set Viewport Scales

❚ For metric drawings, the 
scales you specify might be 
1:20 and 1:10. 

❚ When layout viewports are 
locked, all pan and zoom 
operations apply 
automatically to the paper 
space layout rather than 
model space.

Things to Try…

Create an additional viewport at 
a smaller scale. You can use it for 
more experiments later.
3 Select the left viewport object. Then click the VP Scale 
button below.

4 On the list of scales, click to select a scale of 
1-1/2" = 1'. 

5 Right-click anywhere in the drawing. On the shortcut 
menu, click Display Locked > Yes.

6 Select the right viewport object. Then click the VP 
Scale button.

7 On the list of scales, click to select a scale of 
3/4" = 1'-0”. 

Notice that the annotation scale is now set 
automatically to the VP scale.

8 Then, right-click anwhere in the drawing. On the 
shortcut menu, click Display Locked > Yes.
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Create Annotative 
Objects

❚ Notice that the current 
multileader style is set to 
annotative. Annotative 
objects adjust automatically 
for specified scales.

❚ This new setting is available 
for the styles of all objects that 
are used to annotate drawings 
such as text, dimensions, 
hatches, and so on.

❚ To use this feature, it is 
recommended that you 
create new annotative styles 
in each of your drawing 
template (DWT) files.

❚ It is easiest to create 
annotative objects in model 
space.
1 Click Format menu > Multileader Style

2 In the Multileader Style Manager, click Modify. Then 
click the Leader Structure tab.

3 Click the other two tabs and verify that the text and 
arrow sizes are specified as their true size for display 
on the layout. Then press ESC twice to exit the 
Multileader Style Manager.

4 Click the Model tab or button to return to model 
space.

5 Zoom into the railing at the top of the retaining wall.
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Create a Multileader

❚ The multileader style uses a 
spline leader with three 
points. 

❚ You need to define a scale to 
display the mleader.

❚ This added scale will be 
applied to the selected 
mleader object in all layout 
viewports that are set to the 
1-1/2" scale.
Set Scales for Annotative Objects

1 Set the current layer to TEXT-NOTES.

2 Click Dimension menu > Multileader. In the dialog 
box, accept the 1:1 scale and click OK. 

3 Enter the following text: JANSEN ORNAMENTAL 
RAIL CAP #SSD2-1/4, H.D.GALV., PAINT. Make the 
multileader look like the following illustration. 

4 Select the multileader and right-click. On the shortcut 
menu, click Annotative Object Scale > Add/Delete 
Scales.

5 In the Annotation Object Scale dialog box, click Add. 
Then click the 1-1/2" = 1'-0" scale on the list and click 
OK. The scale is added as shown. Click OK.
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❚ Notice that the mleader is 
displayed at the correct scale 
in the left viewport.

❚ It is not displayed in the right 
viewport because that 
viewport is at a different scale.

❚ Both views now display a 
correctly scaled mleader.

❚ Notice that all scales of the 
mleader are made visible. This 
effect can be turned on and 
off with a system variable.

Things to Try…

Add several other multileaders, 
repeating the process. Then add 
some annotative dimensions.
6 Click the Layout tab or button. Enter model space in 
the left viewport. Double-click the text in the 
multileader and resize the width as shown.

7 Click the Model tab or button. 

8 Select the multileader and right-click. On the shortcut 
menu, click Annotative Object Scale > Add/Delete 
Scales.

9 In the Annotation Object Scale dialog box, click Add. 
Then click the 3/4" = 1'-0" scale on the list and click 
OK.

10 Click the Layout tab or button. Resize the width of 
the multileader text as shown.

11 Click the Model tab or button and then select the 
mleader. Then click ESC to deselect the multileader.
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Create Versions of the 
Same Annotative Object

❚ With different scales, 
annotative objects might 
need to be relocated to 
prevent them from 
overlapping other objects.

❚ The same mleader object is 
displayed differently in both 
viewports.

Annotation Visibility

❚ The display of the new 
multileader is turned on and 
off in both layout viewports.

❚ The Annotation Visibility 
button can also be used on 
the Model tab to display all 
annotative objects regardless 
of scale. This can be useful as 
a reference when creating 
annotative objects.

Things to Try…

Add more mleaders. Modify 
their locations in different layout 
viewports.
Adjust Annotative Objects

1 Click the Layout tab or button.

2 In the right viewport, select the mleader and use grip 
editing to relocate the mleader text as shown.

3 Press ESC to exit grip editing and return to paper 
space.

4 Click the Model tab or button and create a new 
mleader object with an annotative scale of 1:1.

5 Click the Layout tab or button.

6 On the Status bar, click to turn the Annotation 
Visibility on and off. 
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Scaling Hatches 

❚ The details in some of your 
existing drawings can be 
modified to take advantage of 
annotative scaling.

❚ In this drawing, you will 
change the EARTH hatch to 
become annotative. The other 
hatches can be left as they 
are.

❚ The EARTH hatch has a model 
space scale of 6.0, but you 
want it to display using the 
same relative size at the 
1-1/2" = 1'-0" scale as on the 
Model tab.

❚ Setting the annotation scale 
in Model space first is the key.

❚ Notice that the Annotative 
Scale property of the selected 
hatch changes automatically.
Make Existing Objects Annotative

1 Click the Model tab or button and zoom to the 
bottom area of the retaining wall section.

2 Change the current annotation scale to 1-1/2" = 1'-0".

3 Select the EARTH hatch on the far-left side of the 
drawing. Then open the Properties palette.

4 Change the Annotative property to Yes, but leave the 
hatch scale set to 6.



Make Existing Objects Annotative | 63

Add Another Scale

❚ Notice that the selected hatch 
already has the 1-1/2" scale 
assigned.

❚ The hatches in both layout 
viewports are displayed at the 
same size. All the scaling 
calculations were done 
automatically.

Things to Try…

Make the other EARTH hatches 
annotative using the same steps.
5 Close the Properties palette.

6 With the hatch selected, right-click. On the shortcut 
menu, click Annotative Object Scale > Add/Delete 
Scales.

7 Click Add and then add the 3/4" = 1'-0" scale to the 
hatch. Click OK to close each dialog box.

8 Click the Layout tab or button and compare the 
hatches.

9 When you are done experimenting, close the file 
without saving it.
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There is a lot more to learn about 
annotation scaling. You have 
learned the two most common 
workflows for using this feature. 
Use the Help system to explore 
the rich set of capabilities and 
options.

Further Study…

Review the following commands 
and system variables, and 
associated User's Guide topics in 
the Help system:

Commands

ANNORESET

ANNOUPDATE

OBJECTSCALE

System Variables

ANNOALLVISIBLE

ANNOAUTOSCALE

ANNOTATIVEDWG

DIMANNO

CANNOSCALE

CANNOSCALEVALUE

MSLTSCALE

SELECTIONANNODISPLAY
What Should You Do Next?

The AutoCAD 2008 New Features guide has provided you 
with an introduction to the major new features in 
AutoCAD 2008. There are many other features in this 
release that can make your work significantly faster and 
easier. Most of these features are described in the New 
Features Workshop. 
When you have reviewed these new features, carefully 
work through the descriptions and procedures in the 
Help system and experiment with them on your own 
drawings.
Additional resources include the following:

❚ Learn how others are using AutoCAD 2008 by visiting 
the AutoCAD 2008 discussion groups.  

❚ Enroll in an update class that uses Autodesk Official 
Training Courseware (AOTC).  You can locate an 
authorized Autodesk Training Center (ATC) near you 
through the Authorized Training Centers page on 
www.autodesk.com.

❚ Access the many self-paced e-Learning lessons right in 
the Help system if you are an Autodesk Subscription 
customer.

Best wishes!



New and Changed Commands and 
System Variables
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Commands
(* = changed command)

-3DCONFIG*
Added plot emulation and texture compression options

ANNORESET
Resets the location of all scale representations for an annotative object to that of the current scale 
representation

ANNOUPDATE
Updates existing annotative objects to match the current properties of their styles

ATTDEF*
Added support for annotative scaling

-ATTDEF*
Added support for annotative scaling

ATTEDIT*
Multiple-line attribute support 

ATTIPEDIT
Changes the textual content of an attribute within a block

AUTOPUBLISH
Publishes drawings to DWF files automatically

BATTMAN*
Added support for annotative scaling

BLOCK*
Added support for annotative scaling

-BLOCK*
Added support for annotative scaling

CHPROP*
Added support for annotative scaling

CUI*
Added dashboard panel customization and some enhancements for customizing toolbars

DASHBOARD*
Added access to the Customize User Interface from the right-click menu
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DATAEXTRACTION
Starts the Data Extraction wizard

-DATAEXTRACTION
Extracts data as specified in an existing attribute extraction template file (BLK, DXE)

DATALINK
Opens the Data Link Manager

DATALINKUPDATE
Updates data to or from an established external data link

DGNADJUST
Changes the display options of selected DGN underlays

DGNATTACH
Attaches a DGN underlay to the current drawing

DGNCLIP
Defines a clipping boundary for a selected DGN underlay

DGNEXPORT
Creates one or more V8 DGN files from the current drawing

DGNIMPORT
Imports the data from a V8 DGN file into a new DWG file

DIMANGULAR*
Added the Quadrant option

DIMBREAK
Adds or removes a dimension break

DIMDIAMETER*
Added the Extension line option

DIMINSPECT
Create or remove inspection dimensions

-DIMINSPECT
Command prompt version of DIMINSPECT

DIMJOGGED*
Added the Extension line option

DIMJOGLINE
Adds or removes a jog line to a linear or aligned dimension

DIMRADIUS*
Added the Extension line option
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DIMSPACE
Adjusts the spacing equally between parallel linear and angular dimensions

DIMSTYLE*
Added new tolerance alignment option, size option for linear jog, and break spacing

-DIMSTYLE*
Command prompt version of DIMSTYLE

DISTANTLIGHT*
Modified to support entering photometric properties

DWFLAYERS
Controls the display of layers in a DWF underlay

EATTEXT*
Now activates the DATAEXTRACTION command rather than the Attribute Extraction wizard

-EATTEXT*
Command prompt version of the EATTEXT command

ETRANSMIT*
Added support for visual fidelity

FREESPOT
Creates free spotlight which is similar to a spotlight without a specified target

FREEWEB
Creates a free web light which is similar to a web light without a specified target

HATCH*
Added support for annotative scaling

-HATCH*
Added support for annotative scaling

HATCHEDIT*
Added support for annotative scaling

-HATCHEDIT*
Added support for annotative scaling

INSERT*
Added support for annotative scaling

-INSERT*
Added support for annotative scaling
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-LAYER*
Added option to import layer states from drawings, the Edit option now includes Material and 
Description suboptions, the Import option now includes DWG/DWS/DWT formats, and the Export 
option includes the .LAY file format

LAYERSTATE
Saves, restores, and manages named layer states

MATCHCELL*
Added support for double line borders, border linetypes, and new cell formats

MLEADER
Creates a line that connects annotation to a feature

MLEADERALIGN
Organizes selected multileaders along a specified line

MLEADERCOLLECT
Organizes selected multileaders containing blocks as content into a group attached to a single leader 
line

MLEADEREDIT
Adds leader lines to, or removes leader lines from, a multileader object

MLEADERSTYLE
Defines a new multileader style

MTEXT*
Added support for annotative scaling

-MTEXT*
Added support for annotative scaling

MVIEW*
When used on a layout, a new option, Layer, removes all layer property override values and resets 
them back to their corresponding global properties

NEWVIEW
Expedites the creation of a new view

OBJECTSCALE
Adds or deletes supported scales for annotative objects

OPTIONS*
Added the Maintain Visual Fidelity checkbox to the Open and Save tab, Added the Display Drawing 
Status Bar checkbox to the Display tab
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PASTESPEC*
Enhanced for when Microsoft Excel data is pasted from the clipboard and you want to create a Data 
Link to this information immediately

PLOT*
Affected by the hardware configuration settings plot emulation and texture compression

POINTLIGHT*
Start and end limits for attenuation are supported with the Direct 3D driver; also added prompting 
for area-sampled shadow options and photometric prompting

QSELECT*
Added support for annotative scaling

QUICKCUI
Displays the Customize User Interface dialog box in a collapsed state

RECOVERALL
Repairs a damaged drawing and xrefs

-RENDER
Added a Command prompt version of the RENDER command

RENDEREXPOSURE
Provides settings to interactively adjust the lighting global for the most recent rendered output

SCALETEXT*
Added support for annotative scaling

SETBYLAYER
Changes property and ByBlock settings for selected objects to ByLayer

SPELL*
Now checks words in dimensions, zooms into words being corrected; added option to ignore words 
with numbers or words with special characters

SPOTLIGHT*
Start and end limits for attenuation are supported with the Direct 3D driver; also added prompting 
for area-sampled shadow options and photometric prompting

STYLE*
Added support for annotative scaling

-STYLE*
Added support for annotative scaling

TABLE*
Added From Style" and Data Link branches
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-TABLE*
Added From Style" and Data Link branches

TABLESTYLE*
Defines a new table style

TARGETPOINT
Creates a target point light

TEXT*
Added support for annotative scaling

TPNAVIGATE
Displays a specified tool palette or palette group

VIEW*
Modified to support the new sky background option, when applicable

-VPORTS*
Added option, LAyer, removes all layer property override values and resets them back to their 
corresponding global properties

WEBLIGHT
Creates a web light

XCLIP*
Added the Invert option
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System Variables
(* = changed system variable)

3DCONVERSIONMODE
Used to convert material and light definitions

3DSELECTIONMODE
Controls the selection precedence of visually overlapping objects when using 3D visual styles

AFLAGS*
Added a value for the new 'Multiple lines" mode.

ANNOALLVISIBLE
Hides or displays annotative objects that do not support the current annotation scale

ANNOAUTOSCALE
Updates annotative objects to support the annotation scale when the annotation scale is changed

ANNOTATIVEDWG
Specifies whether or not the drawing will behave as an annotative block when inserted into another 
drawing

ATTIPE
Controls the display of the in-place editor used to create multiline attributes

ATTMULTI
Controls whether multiline attributes can be created

AUTODWFPUBLISH
Controls whether the AutoPublish feature is on or off

CANNOSCALE
Sets the name of the current annotation scale for the current space

CANNOSCALEVALUE
Returns the value of the current annotation scale

CMLEADERSTYLE
Determines the current multileader style

COPYMODE
Controls whether the COPY command repeats automatically

DATALINKNOTIFY
Controls the notification for updated or missing data links
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DCTMAIN*
Displays the three letter keyword of the current main spelling dictionary

DGNFRAME
Determines whether DGN underlay frames are visible or plotted in the current drawing

DGNOSNAP
Controls object snapping for geometry in DGN underlays

DIMANNO
Indicates whether or not the current dimension style is annotative

DIMSCALE*
Now is automatically set to 0 when an annotative dimension style is made current

DXEVAL
Controls when data extraction tables are compared against the data source, and if the data is not 
current, displays an update notification

HPMAXLINES
Controls the maximum number of hatch lines that will generate

LAYEREVAL
Controls when the Unreconciled New Layer filter list in the Layer Properties Manager is evaluated 
for new layers

LAYERNOTIFY
Specifies when an alert displays for new layers that have not yet been reconciled

LAYLOCKFADECTL
Controls the dimming for objects on locked layers

LIGHTINGUNITS
Controls whether generic or photometric lights are used, and indicates the current lighting units

LIGHTSINBLOCKS
Controls whether lights contained in blocks are used when rendering

LINEARBRIGHTNESS
Controls the global brightness level of the drawing when using default lighting or generic lights

LINEARCONTRAST
Controls the global contrast level of the drawing when using default lighting or generic lights

LOGEXPBRIGHTNESS
Controls the global brightness level of the drawing when using photometric lighting

LOGEXPCONTRAST
Controls the global contrast level of the drawing when using photometric lighting
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LOGEXPDAYLIGHT
Controls if exterior daylight is used when using photometric lighting

LOGEXPMIDTONES
Controls the global mid tones level of the drawing when using photometric lighting

MSLTSCALE
Scales linetypes displayed on the model tab by the annotation scale

PERSPECTIVECLIP
Determines the location of eye-point clipping

PUBLISHCOLLATE
Controls whether plotting a sheet set, multi-sheet plot file, or plot spool file can be interrupted by 
other plot jobs

RENDERUSERLIGHTS
Controls whether user-lights are translated during rendering

SAVEFIDELITY
Controls whether the drawing is saved with visual fidelity

SELECTIONANNODISPLAY
Controls whether alternate scale representations are temporarily displayed in a dimmed state when 
an annotative object is selected

SETBYLAYERMODE
Controls which properties are selected for SETBYLAYER

TABLETOOLBAR
Controls the display of the Table Toolbar

TEXTOUTPUTFILEFORMAT
Provides Unicode options for plot and text window log files

VPLAYEROVERRIDES
Indicates if there are any layers with viewport (VP) property overrides for the current layout viewport

VPLAYEROVERRIDESMODE
Controls whether layer property overrides associated with layout viewports are displayed and 
plotted
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